<!DOCTYPE html>
<!--[if IE 8]> <html lang="en" class="no-js ie-browser lt-ie9"> <![endif]-->
<!--[if IE 9]> <html lang="en" class="no-js ie-browser ie9"> <![endif]-->
<!--[if gt IE 9]><!--> <html lang="en" class="no-js"> <!--<![endif]-->
<head>

	<script>(function(H){H.className=H.className.replace(/\bno-js\b/,'js')})(document.documentElement)</script>

	<meta charset="UTF-8">
	<meta http-equiv="X-UA-Compatible" content="IE=Edge">
	<meta name="viewport" content="width=device-width, initial-scale=1.0">

	<link rel="profile" href="http://gmpg.org/xfn/11">
	<link rel="pingback" href="https://thebiglead.com/xmlrpc.php">

	
	<!--[if lt IE 9]>
    <script src="https://s0.wp.com/wp-content/themes/vip/usatoday-lawrence/js/lib/html5.js" type="text/javascript"></script>
	<link rel="stylesheet" type="text/css" href="https://s0.wp.com/wp-content/themes/vip/usatoday-lawrence/ie8.css">
	<![endif]-->

	<!--[if gte IE 9]>
	<link rel="stylesheet" type="text/css" href="https://s0.wp.com/wp-content/themes/vip/usatoday-lawrence/ie9.css">
	<![endif]-->

	
	
<meta name="description" content="Honesty is the best and only policy." />
<meta name="keywords" content="nfl, cleveland browns, jim mora, josh rosen, news, nfl draft, sam darnold, ucla" />
<title>Josh Rosen&#8217;s Former Coach: Draft Sam Darnold | The Big Lead</title>
<meta name="google-site-verification" content="O1Fe2GkqKdGA_B5lGGdLjmym5ST4_a_SksWfYv6kROM" />
		<script src='https://r-login.wordpress.com/remote-login.php?action=js&amp;host=thebiglead.com&amp;id=55735640&amp;t=1522164676&amp;back=https%3A%2F%2Fthebiglead.com%2F2018%2F03%2F27%2Fjim-mora-josh-rosen-sam-darnold%2F' type="text/javascript"></script>
		<script type="text/javascript">
		/* <![CDATA[ */
			if ( 'function' === typeof WPRemoteLogin ) {
				document.cookie = "wordpress_test_cookie=test; path=/";
				if ( document.cookie.match( /(;|^)\s*wordpress_test_cookie\=/ ) ) {
					WPRemoteLogin();
				}
			}
		/* ]]> */
		</script>
		<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//native.sharethrough.com' />
<link rel='dns-prefetch' href='//mtrx.go.sonobi.com' />
<link rel='dns-prefetch' href='//usatodaysports-d.openx.net' />
<link rel='dns-prefetch' href='//js-sec.indexww.com' />
<link rel='dns-prefetch' href='//tags.tiqcdn.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//usatthebiglead.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="The Big Lead &raquo; Feed" href="https://thebiglead.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Big Lead &raquo; Comments Feed" href="https://thebiglead.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Big Lead &raquo; Josh Rosen&#039;s Former Coach: Draft Sam Darnold Comments Feed" href="https://thebiglead.com/2018/03/27/jim-mora-josh-rosen-sam-darnold/feed/" />
	<script type="text/javascript">
		/* <![CDATA[ */
		function addLoadEvent(func) {
			var oldonload = window.onload;
			if (typeof window.onload != 'function') {
				window.onload = func;
			} else {
				window.onload = function () {
					oldonload();
					func();
				}
			}
		}
		/* ]]> */
	</script>
			<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s1.wp.com\/wp-includes\/js\/wp-emoji-release.min.js?m=1516999477h&ver=4.9.5-beta1-42868"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='all-css-0-1' href='https://s1.wp.com/_static/??-eJyNUNFOwzAM/CFCVBjjCfEZPLupybw6cVSn6/r3pKsKGoxoL9GdfWdfbKdknMSMMdswmsSjp6h2Sk6C0UCM8y/26FQf7G0bU49qj5gTuN5cWE3uZMBSDwnyogjYESBjKLKabaLOYy523bDJeK5aQtpvixZ4KPGqydYft20aUNWUN9AYTD6UbH99a9meKNlRIUsH8/cgzeT62VBkimhO1KGswW817prMMA0YHW7ND1Bo6Z57qTgCNlQk12Q1k42S1+YGalM9imFxkEniFTGfDDTUrAO2LL5AfznFD/3vAIed9Swt8CJ4D2/Ny1PT7Pavz83xC1hICYA=?cssminify=yes' type='text/css' media='all' />
<script>var googletag_cmd_push = function(o){ return googletag.cmd.push( o ); };</script><script src="https://run.adrizer.com/track.js" id="ADRIZER_JS" data-domain="thebiglead.com/"></script><script type='text/javascript'>
/* <![CDATA[ */
var amznAcctId = ["3090"];
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var prebidOptions = {"timeout":"1000","prebid":[{"name":"_d_banner_flex","appnexus":7467610,"indexId":101,"indexSiteId":175901,"rubiconAccountId":10968,"rubiconSiteId":26280,"rubiconZoneId":261670},{"name":"_d_atf_flex","appnexus":7467638,"indexId":102,"indexSiteId":175902,"rubiconAccountId":10968,"rubiconSiteId":26280,"rubiconZoneId":261670},{"name":"_d_btf_flex","appnexus":7467666,"indexId":103,"indexSiteId":175903,"rubiconAccountId":10968,"rubiconSiteId":26280,"rubiconZoneId":261670},{"name":"_mw_320x50","appnexus":7467694,"indexId":104,"indexSiteId":175904,"rubiconAccountId":10968,"rubiconSiteId":33144,"rubiconZoneId":261676},{"name":"_mw_300x250","appnexus":7467724,"indexId":105,"indexSiteId":175905,"rubiconAccountId":10968,"rubiconSiteId":33144,"rubiconZoneId":261676}],"tablet":"","mobile":""};
/* ]]> */
</script>
<script type='text/javascript'>
!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");window.bidSlots=window.bidSlots||[];window._mweb=0;apstag.init({pubID: amznAcctId, adServer: "googletag"});
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??-eJyVjt0KwjAMRl/Irmyi7kZ8lq6NM3X9MWk35tPbgV6IQxECgeR8J5FTFOj1kA2wtKVuGWh+tsryRn4DhMOeVILKoX/BOvgEPi2sCx0OIDIDqb7MiugcVrgYODlgLtDK9v0l9CPC9BOzkKLSV0HAeP+wpguUe3LEKDOrFIyaxaAmAq9hcXVoDJBwypeX6N90JCgC0ZTcyR3rXb1t2nbfHOwDudSIEA=='></script>
<script type='text/javascript' src='https://mtrx.go.sonobi.com/morpheus.usatoday.1587.js?ver=4.9.5-beta1-42868'></script>
<script type='text/javascript' src='https://usatodaysports-d.openx.net/w/1.0/jstag?nc=7103-USA_RON&#038;ver=4.9.5-beta1-42868'></script>
<script type='text/javascript' async src='https://js-sec.indexww.com/ht/p/184031-126856402220676.js?ver=4.9.5-beta1-42868'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var heapTrackingId = "2876821568";
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/wp-content/themes/vip/usatoday-lawrence/modules/analytics-scripts/js/heap-tracking.js?m=1488398770h'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var utag_data = {"ssts":"sports:thebiglead","priority_asset":"","blogname":"thebiglead","videoincluded":"no","platform":"desktop","contenttype":"story pages","assetid":"612778","headline":"Josh Rosen's Former Coach: Draft Sam Darnold","byline":"Kyle Koster","taxonomykeywords":"Cleveland Browns, Jim Mora, Josh Rosen, News, NFL Draft, Sam Darnold, UCLA"};
/* ]]> */
</script>
<script type='text/javascript'>
					utag_data.clickPage = sessionStorage.getItem( "clickPage" );
					sessionStorage.setItem( "clickPage", window.location.href );
					
</script>
<script type='text/javascript' src='https://tags.tiqcdn.com/utag/gci/thebiglead/prod/utag.js?ver=4.9.5-beta1-42868'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var usatoday_gallery_ajax_object = {"publisherGA":"UA-1004517-1","sharethispubid":"fd7eb3e3-60ab-4eeb-9e7b-cb89e8ec8c83"};
var _usmgOptions = {"ipdir":"r","gaid":"UA-1004517-1","dfpid":"7103","pid":"SMG_TBL_OO","ads":[],"tlmurl":"https:\/\/tags.tiqcdn.com\/utag\/gci\/thebiglead\/prod\/utag.js"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/_static/??-eJytkN1uwjAMRl9owQoI7QrtUZBJTevW+VmctOPtlwkB29WoxJ3lz+fINizJuBgKhQJlIE8KMyeoiiV2eDGCS6bgCHzsqrT0lLkfioszwahQCIWrN4/uZtQ3+EeapPYcFDCx6VGEMrcRVKWiv63X7PIKZdUutf7SIjPbzfYZ5/32xuvEyQiHyZyjq2rO/LVWMX7Wn2M8cliLCp9uuBZ201Mv+bM+d/luaPV63iehYyZ0Q2M//MHu7ftuv7V2N34DLljbBg=='></script>
<link rel='stylesheet' id='all-css-0-2' href='https://s1.wp.com/wp-content/mu-plugins/highlander-comments/style.css?m=1377793621h&cssminify=yes' type='text/css' media='all' />
<!--[if lt IE 8]>
<link rel='stylesheet' id='highlander-comments-ie7-css'  href='https://s1.wp.com/wp-content/mu-plugins/highlander-comments/style-ie7.css?m=1351637563h&#038;ver=20110606' type='text/css' media='all' />
<![endif]-->
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://usatthebiglead.wordpress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s1.wp.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress.com" />
<link rel='shortlink' href='https://wp.me/p3LRnW-2zpw' />
<link rel="alternate" type="application/json+oembed" href="https://public-api.wordpress.com/oembed/?format=json&amp;url=https%3A%2F%2Fthebiglead.com%2F2018%2F03%2F27%2Fjim-mora-josh-rosen-sam-darnold%2F&amp;for=wpcom-auto-discovery" /><link rel="alternate" type="application/xml+oembed" href="https://public-api.wordpress.com/oembed/?format=xml&amp;url=https%3A%2F%2Fthebiglead.com%2F2018%2F03%2F27%2Fjim-mora-josh-rosen-sam-darnold%2F&amp;for=wpcom-auto-discovery" />
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Josh Rosen&#039;s Former Coach: Draft Sam Darnold" />
<meta property="og:url" content="https://thebiglead.com/2018/03/27/jim-mora-josh-rosen-sam-darnold/" />
<meta property="og:description" content="Honesty is the best and only policy." />
<meta property="article:published_time" content="2018-03-27T12:53:26+00:00" />
<meta property="article:modified_time" content="2018-03-27T12:53:26+00:00" />
<meta property="og:site_name" content="The Big Lead" />
<meta property="og:image" content="https://usatthebiglead.files.wordpress.com/2017/01/gettyimages-624468838.jpg?w=1024&amp;h=576&amp;crop=1" />
<meta property="og:image:width" content="1024" />
<meta property="og:image:height" content="576" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@thebiglead" />
<meta name="twitter:text:title" content="Josh Rosen&#039;s Former Coach: Draft Sam Darnold" />
<meta name="twitter:image:src" content="https://usatthebiglead.files.wordpress.com/2017/01/gettyimages-624468838.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@KyleKoster" />
<meta property="article:publisher" content="http://facebook.com/thebiglead" />
<meta property="article:author" content="https://www.facebook.com/kyle.a.koster" />
<link rel="shortcut icon" type="image/x-icon" href="https://secure.gravatar.com/blavatar/fb4f334af3c79a9b2ff6eae662f091cb?s=32" sizes="16x16" />
<link rel="icon" type="image/x-icon" href="https://secure.gravatar.com/blavatar/fb4f334af3c79a9b2ff6eae662f091cb?s=32" sizes="16x16" />
<link rel="apple-touch-icon-precomposed" href="https://secure.gravatar.com/blavatar/fb4f334af3c79a9b2ff6eae662f091cb?s=114" />
<link rel='openid.server' href='https://usatthebiglead.wordpress.com/?openidserver=1' />
<link rel='openid.delegate' href='https://usatthebiglead.wordpress.com/' />
<link rel="search" type="application/opensearchdescription+xml" href="https://thebiglead.com/osd.xml" title="The Big Lead" />
<link rel="search" type="application/opensearchdescription+xml" href="https://s1.wp.com/opensearch.xml" title="WordPress.com" />
<style type="text/css">
.articleBody a,
.author__description a,
.search-no-results .entry-content a,
.archive-no-results .entry-content a,
.nav__item--parent > a:after,
.nav__item--podcast .nav__item-link,
.mobile-nav__item--podcast .mobile-nav__item-link,
.mobile-nav__footer-menu .mobile-nav__item a:active,
.trending__item:before,
.trending__link,
.hero__shares,
.column h3 > a:hover,
.second-tab-content p > a:hover,
.single-related p > a:hover,
.sidebar-upper .widget_usat_sidebar_top_posts_widget .text-block a:hover,
.widget--box .text-block a:hover,
.widget--section-promo p > a:hover,
.column .meta-info a,
.zone--video .medium .author a,
.block--hero .reply-block,
.social-cta__button,
.social-cta__notice--error,
#footer-info .togglee a:hover,
#footer-info .togglee a:active,
.article__subheading,
.articleBody h2,
.search-no-results .entry-content h2,
.archive-no-results .entry-content h2,
.article__author a,
.author__twitter a,
.articleBody .pq,
.search-no-results .entry-content .pq,
.archive-no-results .entry-content .pq,
.single-related .block__shares,
.widget--section-promo .block__shares,
.article__back:before,
.article__back:hover,
.archive .heading .taxonomy,
.search-results .heading .taxonomy,
.search-results .heading > span,
.archive.author .heading h1 a,
.widget_text .textwidget a,
.sidebar-upper .widget_usat_sidebar_top_posts_widget .text-block > h2,
.widget--box .text-block > h2,
.widget--author a,
.newsletter-close-alt a,
.related .block__title:hover,
.hero__secondary .hero__link:hover .hero__title {
	color: #157aaf;
}

.mobile-stream-tabs h2,
.column .heading-small h2,
.sidebar-upper .widget .heading-small h2,
.single-related .heading-small h2,
#video-container .heading-small h2,
.mobile-stream-tabs > div {
	border-bottom-color: #157aaf;
}

@media all and (min-width: 1000px) {
	.branding__logo-link {
		border-bottom-color: #157aaf;
	}
}

.article__pagination .article__pagination__button:hover,
.article__pagination .article__pagination__link:hover,
.article__pagination .article__pagination__button:active,
.article__pagination .article__pagination__link:active {
	border-color: #157aaf;
}

.nav__item:hover,
.nav__item--current,
#footer-info {
	border-top-color: #157aaf;
}

.articleBody blockquote:not(.pq),
.search-no-results .entry-content blockquote:not(.pq),
.archive-no-results .entry-content blockquote:not(.pq) {
	border-left-color: #157aaf;
}

.article__back,
.newsletter__input,
.daily-newsletter__input {
	border-color: #157aaf;
}

.vertical-gallery--icon,
.vertical-gallery__overlay,
.hero__label,
.column .block .img-holder .meta,
.second-tab-content h2,
.single-related .fixed-height-img-holder.link .meta,
.mobile-nav__menu .mobile-nav__item > a:active,
.mobile-nav__menu .mobile-nav__item--current > a,
.article__pagination__current,
.articleBody:after,
.search-no-results .entry-content:after,
.archive-no-results .entry-content:after,
.story-share-buttons .share-count,
.newsletter__button,
.daily-newsletter__button {
	background-color: #157aaf;
}

.newsletter__button:after,
.daily-newsletter__button:after {
	background-color: #157aaf;
}

@media all and (min-width: 1000px) {
	.branding {
		border-bottom-color: #157aaf;
	}
}
</style>
<link rel="canonical" href="https://thebiglead.com/2018/03/27/jim-mora-josh-rosen-sam-darnold/" />
<style type="text/css" media="screen">#wpstats{
height:0px;
position:absolute;
}</style>		<style>
			.wpcom-related-posts ul li {
				list-style-type: none;
				display: inline-block;
			}
		</style>
		<meta name="application-name" content="The Big Lead" /><meta name="msapplication-window" content="width=device-width;height=device-height" /><meta name="msapplication-tooltip" content="Sports News and Media" /><meta name="msapplication-task" content="name=Subscribe;action-uri=https://thebiglead.com/feed/;icon-uri=https://secure.gravatar.com/blavatar/fb4f334af3c79a9b2ff6eae662f091cb?s=16" />
<!-- Include google_services.js -->
<script async="async" src="https://www.googletagservices.com/tag/js/gpt.js"></script>
<script>
	var bottomAdMobileRendered = false,
		googletag = googletag || {},
		bidTimeout;
	googletag.cmd = googletag.cmd || [];
	bidManager.timeout = 2500;
	bidManager.addBidder('a9');
		bidManager.addBidSlot({ slotID: "videoSlot", mediaType : 'video' } );

	</script>
<!-- helper function for targeting the url -->
<script type='text/javascript'>
(function(e,t){function i(){e.googletag=e.googletag||{};e.sdpTargeting=this.urlTargeting();e._sitePage=e.sdpTargeting.sp}var n,r;i.prototype.urlTargeting=function(){var t=e.location.pathname.replace(/\/$/,""),n=new RegExp("/([^/]*)","ig"),r=t.match(n),i=["/"],s="";if(r&&t!=="/"){var o="",u=r.length;if(u>0){for(var a=0;a<u;a++){o=r[a];i.push(o);for(var f=a+1;f<u;f++){o+=r[f];i.push(o)}if(a===0){i.splice(-1,1);s=o}}}i.push(s)}i=i.reverse();var l=e.location.toString().replace(/\=/ig,":").match(/\?(.+)$/),c=RegExp.$1.split("&"),h=e.location.toString().replace(/\/*(\?|\&|\x26)*(\w+=\w+)*$/,"");var p=h.replace(/http:\/\//,"").split("/");var d=p.length==1?"main":p[1].match(/^$|^index\.(php|htm|html)+$/i)?"main":"general";return{title:h,targetPaths:i.slice(0,9),fullPath:i[0],queryStr:c,domainName:e.location.hostname,sp:d}};n=new i})(window,document)
</script>
<script type='text/javascript'>
if (typeof amznads !== "undefined") {
	var key = 'amznslots';
	var values = amznads.getTokens(); //comma separated
}
</script>
<script type='text/javascript'>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</script>
<link rel="amphtml" href="https://thebiglead.com/2018/03/27/jim-mora-josh-rosen-sam-darnold/amp/"><style type="text/css" id="syntaxhighlighteranchor"></style>
		<link rel="stylesheet" id="custom-css-css" type="text/css" href="https://s2.wp.com/?custom-css=1&#038;csblog=3LRnW&#038;cscache=6&#038;csrev=61" />
		
	<script type="text/javascript">
		var is_user_logged_in = 0;
	</script>

</head>

<body class="post-template-default single single-post postid-612778 single-format-standard mp6 customizer-styles-applied single-post--section highlander-enabled highlander-light">

	
	<div id='acm-ad-tag-lawrence_dfp_desktop_skin' style='width:1px; height:1px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_desktop_skin'); });</script></div><div id='acm-ad-tag-lawrence_dfp_desktop_interstitial' style='width:2px; height:1px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_desktop_interstitial'); });</script></div><div id='acm-ad-tag-lawrence_dfp_desktop_outstream' style='width:4px; height:1px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_desktop_outstream'); });</script></div>
	
<div id="wrapper">

	<div class="sticky-header-ad-above-nav-extra-space"></div>
<div id="header-ad" class="  header-ad--above-nav sticky-header-ad-above-nav">
	<div id='acm-ad-tag-lawrence_dfp_desktop_top' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_desktop_top'); });</script></div></div>
<div class="sticky-header-ad-below-nav-extra-space"></div>

	<div class="wrapper-holder">

		<div
	class="branding branding--section"
	id="nav-branding"
	style="background-image: url( 'https://usatthebiglead.files.wordpress.com/2016/01/sectionhead-football-2x1.jpg' );"
>
	<span class="branding__logos">
					<a
				href="https://thebiglead.com"
				title="The Big Lead"
				class="branding__logo-link branding__logo-link--home"
			>
				<img
					src="https://usatthebiglead.files.wordpress.com/2016/01/tbl-logo-on-dark-2x.png"
					alt="The Big Lead"
					class="branding__logo"
					height="30"
								>
			</a>
		
					<a
				href="https://thebiglead.com/category/nfl/"
				title="The Big Lead"
				class="branding__logo-link branding__logo-link--section"
			>
				<span class="branding__section">NFL</span>
			</a>
			</span>

	
	<span class="branding__search">
		<form method="get" class="branding__search-form" action="https://thebiglead.com" role="search">
			<input type="text" name="s" value="" placeholder="search The Big Lead" class="branding__search-input">
			<a class="branding__search-close"></a>
		</form>
	</span>

			<a class="branding__brand" href="http://usatodaysports.com" target="_blank" title="USA TODAY Sports">
			<img src="https://usatthebiglead.files.wordpress.com/2015/11/usat-logo-header-rev.png" alt="USA Today Sports" class="branding__brand-image" height="24">
		</a>
		<a class="branding__mobile"></a>
</div>
<header class="nav  ">
	<nav class="nav__wrap">
		<ul class="nav__menu">
			<li id="menu-item-299904" class="nav__item nav__item--nfl"><a href="https://thebiglead.com/category/nfl/">NFL</a></li>
<li id="menu-item-396634" class="nav__item nav__item--ncaaf"><a href="https://thebiglead.com/category/college-football/">NCAAF</a></li>
<li id="menu-item-299906" class="nav__item nav__item--nba"><a href="https://thebiglead.com/category/nba/">NBA</a></li>
<li id="menu-item-396641" class="nav__item nav__item--ncaab"><a href="https://thebiglead.com/category/college-basketball/">NCAAB</a></li>
<li id="menu-item-322780" class="nav__item nav__item--mlb"><a href="https://thebiglead.com/category/mlb/">MLB</a></li>
<li id="menu-item-462780" class="nav__item nav__item--golf"><a href="https://thebiglead.com/category/golf/">GOLF</a></li>
<li id="menu-item-338797" class="nav__item nav__item--media"><a href="https://thebiglead.com/category/media-gossipmusings/">MEDIA</a></li>
<li id="menu-item-485396" class="nav__item nav__item--soccer"><a href="https://thebiglead.com/category/soccer/">SOCCER</a></li>
<li id="menu-item-550817" class="nav__item nav__item--wwe"><a href="https://thebiglead.com/category/wwe/">WWE</a></li>
<li id="menu-item-396635" class="nav__item nav__item--wags"><a href="https://thebiglead.com/category/athlete-girlfriends/">WAGS</a></li>
<li id="menu-item-485401" class="nav__item nav__item--rugby"><a href="https://thebiglead.com/category/rugby/">RUGBY</a></li>
<li id="menu-item-322764" class="nav__item nav__item--roundup"><a href="https://thebiglead.com/category/roundup/">ROUNDUP</a></li>
<li id="menu-item-485402" class="nav__item nav__item--gifs"><a href="https://thebiglead.com/tag/gif/">GIFs</a></li>
<li id="menu-item-485403" class="nav__item nav__item--podcasts"><a href="https://thebiglead.com/category/podcasts/">PODCASTS</a></li>
		</ul>
		<ul class="nav__social nav__social--section">
			<li class="nav__item nav__item--social nav__item--facebook">
			<a href="http://facebook.com/thebiglead" class="nav__item-link"></a>
		</li>
			<li class="nav__item nav__item--social nav__item--twitter">
			<a href="https://twitter.com/thebiglead" class="nav__item-link"></a>
		</li>
			<li class="nav__item nav__item--social nav__item--instagram">
			<a href="http://instagram.com/thebiglead" class="nav__item-link"></a>
		</li>
			<li class="nav__item nav__item--social nav__item--podcast">
			<a href="https://thebiglead.com/category/podcasts/" class="nav__item-link"></a>
		</li>
	</ul>
	</nav>
</header>

		
		<nav class="trending">
	<h3 class="trending__title">Trending:</h3>

	<ul class="trending__list">
					<li class="
				trending__item
				trending__item--odellbeckhamjr							">

				<a href="https://thebiglead.com/tag/odell-beckham-jr/" data-track="thebigleadautotrending" class="trending__link">
					Odell Beckham Jr.				</a>


			</li>
					<li class="
				trending__item
				trending__item--commentary							">

				<a href="https://thebiglead.com/tag/commentary/" data-track="thebigleadautotrending" class="trending__link">
					Commentary				</a>


			</li>
					<li class="
				trending__item
				trending__item--kawhileonard							">

				<a href="https://thebiglead.com/tag/kawhi-leonard/" data-track="thebigleadautotrending" class="trending__link">
					Kawhi Leonard				</a>


			</li>
					<li class="
				trending__item
				trending__item--odellbeckham							">

				<a href="https://thebiglead.com/tag/odell-beckham/" data-track="thebigleadautotrending" class="trending__link">
					Odell Beckham				</a>


			</li>
					<li class="
				trending__item
				trending__item--terrellowens							">

				<a href="https://thebiglead.com/tag/terrell-owens/" data-track="thebigleadautotrending" class="trending__link">
					Terrell Owens				</a>


			</li>
					<li class="
				trending__item
				trending__item--stormydaniels							">

				<a href="https://thebiglead.com/tag/stormy-daniels/" data-track="thebigleadautotrending" class="trending__link">
					Stormy Daniels				</a>


			</li>
					<li class="
				trending__item
				trending__item--sanantoniospurs							">

				<a href="https://thebiglead.com/tag/san-antonio-spurs/" data-track="thebigleadautotrending" class="trending__link">
					San Antonio Spurs				</a>


			</li>
					<li class="
				trending__item
				trending__item--stephenjackson							">

				<a href="https://thebiglead.com/tag/stephen-jackson/" data-track="thebigleadautotrending" class="trending__link">
					Stephen Jackson				</a>


			</li>
					<li class="
				trending__item
				trending__item--greggpopovich							">

				<a href="https://thebiglead.com/tag/gregg-popovich/" data-track="thebigleadautotrending" class="trending__link">
					Gregg Popovich				</a>


			</li>
					<li class="
				trending__item
				trending__item--billbelichick							">

				<a href="https://thebiglead.com/tag/bill-belichick/" data-track="thebigleadautotrending" class="trending__link">
					Bill Belichick				</a>


			</li>
					<li class="
				trending__item
				trending__item--colincowherd							">

				<a href="https://thebiglead.com/tag/colin-cowherd/" data-track="thebigleadautotrending" class="trending__link">
					Colin Cowherd				</a>


			</li>
					<li class="
				trending__item
				trending__item--jimmygaroppolo							">

				<a href="https://thebiglead.com/tag/jimmy-garoppolo/" data-track="thebigleadautotrending" class="trending__link">
					Jimmy Garoppolo				</a>


			</li>
					<li class="
				trending__item
				trending__item--sanfrancisco49ers							">

				<a href="https://thebiglead.com/tag/san-francisco-49ers/" data-track="thebigleadautotrending" class="trending__link">
					San Francisco 49ers				</a>


			</li>
					<li class="
				trending__item
				trending__item--wags							">

				<a href="https://thebiglead.com/tag/wags/" data-track="thebigleadautotrending" class="trending__link">
					WAGs				</a>


			</li>
					<li class="
				trending__item
				trending__item--carmeloanthony							">

				<a href="https://thebiglead.com/tag/carmelo-anthony/" data-track="thebigleadautotrending" class="trending__link">
					Carmelo Anthony				</a>


			</li>
			</ul>

</nav>

		<div id="main" class="site-main ">

			

<div id="primary" class="content-area">
	<div id="content" class="site-content" role="main">

		
		
			<article id="post-612778" class="post-612778 post type-post status-publish format-standard has-post-thumbnail hentry category-nfl tag-cleveland-browns tag-jim-mora tag-josh-rosen tag-news tag-nfl-draft tag-sam-darnold tag-ucla" itemscope itemtype="http://schema.org/NewsArticle">

				<div class="article__title ">
	<h1 class="article__headline">Josh Rosen's Former Coach: Draft Sam Darnold</h1>

			<img width="1000" height="600" src="https://s0.wp.com/wp-content/themes/vip/plugins/lazy-load-0.7/images/1x1.trans.gif" class="article__image wp-post-image" alt data-attachment-id="557194" data-permalink="https://thebiglead.com/2017/01/05/jim-mora-says-a-spread-team-hasnt-won-a-title-jim-mora-is-hilariously-wrong/usc-v-ucla-5/" data-orig-file="https://usatthebiglead.files.wordpress.com/2017/01/gettyimages-624468838.jpg" data-orig-size="1024,732" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;4&quot;,&quot;credit&quot;:&quot;Getty Images&quot;,&quot;camera&quot;:&quot;NIKON D4S&quot;,&quot;caption&quot;:&quot;PASADENA, CA - NOVEMBER 19:  Head Coach Jim Mora of the UCLA Bruins on the sidelines before the game against the USC Trojans at Rose Bowl on November 19, 2016 in Pasadena, California.  (Photo by Harry How\/Getty Images)&quot;,&quot;created_timestamp&quot;:&quot;1479581206&quot;,&quot;copyright&quot;:&quot;2016 Getty Images&quot;,&quot;focal_length&quot;:&quot;260&quot;,&quot;iso&quot;:&quot;5000&quot;,&quot;shutter_speed&quot;:&quot;0.0015625&quot;,&quot;title&quot;:&quot;USC v UCLA&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="USC v UCLA" data-image-description data-medium-file="https://usatthebiglead.files.wordpress.com/2017/01/gettyimages-624468838.jpg?w=300" data-large-file="https://usatthebiglead.files.wordpress.com/2017/01/gettyimages-624468838.jpg?w=1000" data-lazy-src="https://usatthebiglead.files.wordpress.com/2017/01/gettyimages-624468838.jpg?w=1000&amp;h=600&amp;crop=1" data-lazy-srcset="https://usatthebiglead.files.wordpress.com/2017/01/gettyimages-624468838.jpg?w=1000&amp;h=600&amp;crop=1 1000w, https://usatthebiglead.files.wordpress.com/2017/01/gettyimages-624468838.jpg?w=640&amp;h=384&amp;crop=1 640w, https://usatthebiglead.files.wordpress.com/2017/01/gettyimages-624468838.jpg?w=300&amp;h=180&amp;crop=1 300w, https://usatthebiglead.files.wordpress.com/2017/01/gettyimages-624468838.jpg?w=768&amp;h=461&amp;crop=1 768w, https://usatthebiglead.files.wordpress.com/2017/01/gettyimages-624468838.jpg?w=1024&amp;h=614&amp;crop=1 1024w" data-lazy-sizes="(max-width: 1000px) 100vw, 1000px"><noscript><img width="1000" height="600" src="https://usatthebiglead.files.wordpress.com/2017/01/gettyimages-624468838.jpg?w=1000&amp;h=600&amp;crop=1" class="article__image wp-post-image" alt="" srcset="https://usatthebiglead.files.wordpress.com/2017/01/gettyimages-624468838.jpg?w=1000&amp;h=600&amp;crop=1 1000w, https://usatthebiglead.files.wordpress.com/2017/01/gettyimages-624468838.jpg?w=640&amp;h=384&amp;crop=1 640w, https://usatthebiglead.files.wordpress.com/2017/01/gettyimages-624468838.jpg?w=300&amp;h=180&amp;crop=1 300w, https://usatthebiglead.files.wordpress.com/2017/01/gettyimages-624468838.jpg?w=768&amp;h=461&amp;crop=1 768w, https://usatthebiglead.files.wordpress.com/2017/01/gettyimages-624468838.jpg?w=1024&amp;h=614&amp;crop=1 1024w" sizes="(max-width: 1000px) 100vw, 1000px" data-attachment-id="557194" data-permalink="https://thebiglead.com/2017/01/05/jim-mora-says-a-spread-team-hasnt-won-a-title-jim-mora-is-hilariously-wrong/usc-v-ucla-5/" data-orig-file="https://usatthebiglead.files.wordpress.com/2017/01/gettyimages-624468838.jpg" data-orig-size="1024,732" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;4&quot;,&quot;credit&quot;:&quot;Getty Images&quot;,&quot;camera&quot;:&quot;NIKON D4S&quot;,&quot;caption&quot;:&quot;PASADENA, CA - NOVEMBER 19:  Head Coach Jim Mora of the UCLA Bruins on the sidelines before the game against the USC Trojans at Rose Bowl on November 19, 2016 in Pasadena, California.  (Photo by Harry How\/Getty Images)&quot;,&quot;created_timestamp&quot;:&quot;1479581206&quot;,&quot;copyright&quot;:&quot;2016 Getty Images&quot;,&quot;focal_length&quot;:&quot;260&quot;,&quot;iso&quot;:&quot;5000&quot;,&quot;shutter_speed&quot;:&quot;0.0015625&quot;,&quot;title&quot;:&quot;USC v UCLA&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="USC v UCLA" data-image-description="" data-medium-file="https://usatthebiglead.files.wordpress.com/2017/01/gettyimages-624468838.jpg?w=300" data-large-file="https://usatthebiglead.files.wordpress.com/2017/01/gettyimages-624468838.jpg?w=1000" /></noscript>		<cite class="article__source"></cite>
		<div class="article__gradient"></div>
	</div>
<h1 class="article__headline article__headline--mobile">Josh Rosen's Former Coach: Draft Sam Darnold</h1>

				<header class="entry-header  ">

					
<h2 class="">
	<a href="https://thebiglead.com/category/nfl/" class="" itemprop="articleSection">NFL</a></h2>

					
					<div id="headline">
						<h1 class="entry-title" itemprop="name headline">Josh Rosen's Former Coach: Draft Sam Darnold</h1>
											</div>

					
					
					<div class="meta-info single-headline" id="entry-byline">
						
<p itemprop="author" itemscope itemtype="http://schema.org/Person">

	By <a href="https://thebiglead.com/author/koster/" title="Posts by Kyle Koster" class="author url fn" rel="author">Kyle Koster</a> 
		<span class="post-date updated">3 hours ago</span>

	
	
					<span class="author-twitter-follow-button">
				<a href="http://twitter.com/KyleKoster" class="twitter-follow-button" data-show-count="false">
					Follow					@KyleKoster				</a>
				<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
			</span>
		
	</p>
					</div>

					<div id='acm-ad-tag-lawrence_dfp_mobile_sponsor_by_logo' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_mobile_sponsor_by_logo'); });</script></div>
				</header>

				
				
				
				<div id="content-container">
					<div class="entry-content normal-format">

						
						<div class="story-share-buttons sms">
	<div class="share-button share-count">
		<span class="icomoon icon-shares"></span>
		<span class="count">2.0k</span>
		<span class="share-text">shares</span>
	</div>
	<div
		data-url="https://thebiglead.com/2018/03/27/jim-mora-josh-rosen-sam-darnold/"
		data-short-url="https://wp.me/p3LRnW-2zpw"
		data-track="thebigleadstoryfb"
		class="share-button share-facebook st-custom-button"
		id="share-facebook"
		data-network="facebook"
	>
		<span class="icomoon icon-facebook"></span>
		<span class="share-text">share</span>
	</div>
	<div
		data-url="https://thebiglead.com/2018/03/27/jim-mora-josh-rosen-sam-darnold/"
		data-short-url="https://wp.me/p3LRnW-2zpw"
		data-track="thebigleadstorytwitter"
		class="share-button share-twitter st-custom-button"
		id="share-twitter"
		data-network="twitter"
		data-username="thebiglead"
	>
		<span class="icomoon icon-twitter"></span>
		<span class="share-text">tweet</span>
	</div>
	<div
		data-url="https://thebiglead.com/2018/03/27/jim-mora-josh-rosen-sam-darnold/"
		data-short-url="https://wp.me/p3LRnW-2zpw"
		data-track="thebigleadstorypinterest"
		class="share-button share-pinterest st-custom-button"
		id="share-pinterest"
		data-network="pinterest"
		data-username=""
	>
		<span class="icomoon icon-pinterest"></span>
		<span class="share-text">pin</span>
	</div>
	<div
		data-url="https://thebiglead.com/2018/03/27/jim-mora-josh-rosen-sam-darnold/"
		data-short-url="https://wp.me/p3LRnW-2zpw"
		data-track="thebigleadstorysms"
		class="share-button share-sms st-custom-button"
		id="share-sms"
		data-network="sms"
	>
		<span class="icomoon icon-sms"></span>
		<span class="share-text">sms</span>
	</div>
	<div
		data-url="https://thebiglead.com/2018/03/27/jim-mora-josh-rosen-sam-darnold/"
		data-short-url="https://wp.me/p3LRnW-2zpw"
		data-track="thebigleadstorywhatsapp"
		class="share-button share-whatsapp st-custom-button"
		id="share-whatsapp"
		data-network="whatsapp"
	>
		<span class="icomoon icon-whatsapp"></span>
		<span class="share-text">send</span>
	</div>

			<div
			data-url="https://thebiglead.com/2018/03/27/jim-mora-josh-rosen-sam-darnold/"
			data-short-url="https://wp.me/p3LRnW-2zpw"
			data-track="thebigleadstoryemail"
			class="share-button share-email st-custom-button"
			id="share-email"
			data-network="email"
			data-message=""
		>
				<span class="icomoon icon-email"></span>
			<span class="share-text">email</span>
		</div>
</div>

						
						<div class="article__author">
	<p itemprop="author" itemscope itemtype="http://schema.org/Person">
		By: <a href="https://thebiglead.com/author/koster/" title="Posts by Kyle Koster" class="author url fn" rel="author">Kyle Koster</a>		| 3 hours ago		<span class="article__author__widgets">
							<span
	class="fb-like author__facebook"
	data-href="https://www.facebook.com/kyle.a.koster"
	data-layout="button"
	data-action="like"
	data-show-faces="true"
	data-share="false"
></span>
<script>(function(d, s, id) {
var js, fjs = d.getElementsByTagName(s)[0];
if (d.getElementById(id)) return;
js = d.createElement(s); js.id = id;
js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.3";
fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));
</script>
										<span class="author-twitter-follow-button author__twitter">
	<a href="http://twitter.com/KyleKoster" class="twitter-follow-button" data-show-count="false">
		Follow @KyleKoster	</a>
	<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
</span>
					</span>
	</p>

	</div>


						<div class="before-article-content widget_text">			<div class="textwidget"><!-- NFL Draft -->

<div style="padding-bottom:20px;border-bottom:1px solid #ddd;">
		<form id="wpcom-iframe-form-67e0a37ea4b6d201e53fbd3dc0c9a607-5aba63c5024fa" target="wpcom-iframe-67e0a37ea4b6d201e53fbd3dc0c9a607-5aba63c5024fa" method="post" action="//wpcomwidgets.com/?wpcom_origin=https%3A%2F%2Fusatthebiglead.wordpress.com" style="display: none">
							<input type="hidden" name="width" value="100%" />
							<input type="hidden" name="height" value="" />
							<input type="hidden" name="frameborder" value="0" />
							<input type="hidden" name="style" value="" />
							<input type="hidden" name="class" value="" />
							<input type="hidden" name="scrolling" value="no" />
							<input type="hidden" name="webkitallowfullscreen" value="" />
							<input type="hidden" name="mozallowfullscreen" value="" />
							<input type="hidden" name="allowfullscreen" value="" />
							<input type="hidden" name="resize" value="0" />
							<input type="hidden" name="replace_attributes" value="1" />
							<input type="hidden" name="fallback" value="&lt;p class=&quot;protected-embed-fallback&quot;&gt;This embed is invalid&lt;/p&gt;" />
							<input type="hidden" name="_data" value="PGRpdiBzdHlsZT0iZGlzcGxheTogYmxvY2s7IHBvc2l0aW9uOiByZWxhdGl2ZTsgbWF4LXdpZHRoOiAxMDAlOyI+PGRpdiBzdHlsZT0icGFkZGluZy10b3A6IDU2LjI1JTsiPjxpZnJhbWUgc3JjPSIvL3BsYXllcnMuYnJpZ2h0Y292ZS5uZXQvMjk5MDYxNzAwMDEvckp4a0FQWkltX2RlZmF1bHQvaW5kZXguaHRtbD9wbGF5bGlzdElkPTU0MDg0MTc4MzQwMDEiIGFsbG93ZnVsbHNjcmVlbj0iIiBzdHlsZT0ibGVmdDogMHB4OyB0b3A6IDBweDsgd2lkdGg6IDEwMCU7IGhlaWdodDogMTAwJTsgcmlnaHQ6IDBweDsgYm90dG9tOiAwcHg7IHBvc2l0aW9uOiBhYnNvbHV0ZTsiIG1vemFsbG93ZnVsbHNjcmVlbiB3ZWJraXRhbGxvd2Z1bGxzY3JlZW4gd2lkdGg9IjEwMCUiIGhlaWdodD0iIiBmcmFtZWJvcmRlcj0iMCIgY2xhc3M9IiIgc2Nyb2xsaW5nPSJubyIgcmVzaXplPSIwIiByZXBsYWNlX2F0dHJpYnV0ZXM9IjEiPjwvaWZyYW1lPjwvZGl2PjwvZGl2Pg==,0ed38c3d301fbc7b42f02b8a91b304eeed69abb3" />
							<input type="hidden" name="_tag" value="protected-iframe" />
							<input type="hidden" name="_hash" value="67e0a37ea4b6d201e53fbd3dc0c9a607" />
					</form>
		
				<iframe
						name="wpcom-iframe-67e0a37ea4b6d201e53fbd3dc0c9a607-5aba63c5024fa"
			id="wpcom-iframe-67e0a37ea4b6d201e53fbd3dc0c9a607-5aba63c5024fa"
			frameborder="0"
			scrolling="no"
			width="100%" 						webkitallowfullscreen mozallowfullscreen allowfullscreen			class="wpcom-protected-iframe "
		></iframe>
		
		<script type="text/javascript">
		( function() {
			var func = function() {
				var iframe_form = document.getElementById('wpcom-iframe-form-67e0a37ea4b6d201e53fbd3dc0c9a607-5aba63c5024fa');
				var iframe = document.getElementById('wpcom-iframe-67e0a37ea4b6d201e53fbd3dc0c9a607-5aba63c5024fa');
				if ( iframe_form && iframe ) {
					iframe_form.submit();
					iframe.onload = function() {
						iframe.contentWindow.postMessage( {
							'msg_type': 'poll_size',
							'frame_id': 'wpcom-iframe-67e0a37ea4b6d201e53fbd3dc0c9a607-5aba63c5024fa'
						}, window.location.protocol + '//wpcomwidgets.com' );
					}
				}

				// Autosize iframe
				var funcSizeResponse = function( e ) {
					var origin = document.createElement( 'a' );
					origin.href = e.origin;

					// Verify message origin
					if ( 'wpcomwidgets.com' !== origin.host )
						return;

					// Verify message is in a format we expect
					if ( 'object' !== typeof e.data || undefined === e.data.msg_type )
						return;

					switch ( e.data.msg_type ) {
						case 'poll_size:response':
							var iframe = document.getElementById( e.data._request.frame_id );

							if ( iframe && '' === iframe.width )
								iframe.width = '100%';
							if ( iframe && '' === iframe.height )
								iframe.height = parseInt( e.data.height );

							return;
						default:
							return;
					}
				}

				if ( 'function' === typeof window.addEventListener ) {
					window.addEventListener( 'message', funcSizeResponse, false );
				} else if ( 'function' === typeof window.attachEvent ) {
					window.attachEvent( 'onmessage', funcSizeResponse );
				}
			}
			if (document.readyState === 'complete') { func.apply(); /* compat for infinite scroll */ }
			else if ( document.addEventListener ) { document.addEventListener( 'readystatechange', function(){ 
if (document.readyState === 'complete') { 
func.apply(); 
} 
},  false ); }
			else if ( document.attachEvent ) { document.attachEvent( 'onreadystatechange', func ); }
		} )();
		</script>
		
</div></div>
		</div>
						<div class="articleBody" itemprop="articleBody"><p><a href="https://thebiglead.com/tag/jim-mora/">Jim Mora</a> coached <a href="https://thebiglead.com/tag/josh-rosen/">Josh Rosen</a> for three seasons at <a href="https://thebiglead.com/tag/ucla/">UCLA</a>. He, more than anyone else, knows what the young quarterback is capable of and what he is not. His advice to the <a href="https://thebiglead.com/tag/cleveland-browns/">Cleveland Browns</a>, who have the pick of any quarterback in the upcoming NFL Draft?</p>
<p><a href="http://www.nfl.com/news/story/0ap3000000923228/article/jim-mora-id-take-darnold-over-rosen-if-i-were-cleveland-browns" target="_blank" rel="noopener">Draft the kid from USC</a>.</p>
<p>&#8220;Because of <i>fit</i>, I would take <a href="https://thebiglead.com/tag/sam-darnold/">Sam Darnold</a> if I were the Cleveland Browns,&#8221; Mora said Monday on NFL Network. &#8220;I think [he has] that blue-collar, gritty attitude. I think his teammates will love him. I think the city will love him. He&#8217;ll say the right things. He&#8217;ll come in and represent well. I think he kind of represents what Cleveland is. And then if I was one of the New York teams, I&#8217;d take Josh like that. I think they&#8217;re both going to be great pros.&#8221;</p>
<p>And you know what? Good for Mora for going out there and serving as the conductor of the Straight Talk Express. If he really believes the Browns would be better off with Darnold, he should say so. It&#8217;s not as if he&#8217;s forever beholden to Rosen and must serve as a hype man.</p>
<p>Besides, Mora has been nothing but consistent with his praise for Rosen during the pre-draft process. It&#8217;s just that he &#8212; along with most other experts &#8212; believe Darnold is a better choice and therefore will come off the board earlier.</p>
<p>&#8220;I think some day hopefully we&#8217;re talking about the Peyton Manning-Tom Brady debate,&#8221; Mora said. &#8220;Which one&#8217;s better? I think both of those guys can be those types of guys.&#8221;</p>
<p>Honesty and bold predictions? If a guy didn&#8217;t know better he&#8217;d think this former coach was angling for a regular analyst job.</p>
</div>

						
						
						<p class="post-tags"><a href="https://thebiglead.com/tag/cleveland-browns/" rel="tag">Cleveland Browns</a>, <a href="https://thebiglead.com/tag/jim-mora/" rel="tag">Jim Mora</a>, <a href="https://thebiglead.com/tag/josh-rosen/" rel="tag">Josh Rosen</a>, <a href="https://thebiglead.com/tag/news/" rel="tag">News</a>, <a href="https://thebiglead.com/tag/nfl-draft/" rel="tag">NFL Draft</a>, <a href="https://thebiglead.com/tag/sam-darnold/" rel="tag">Sam Darnold</a>, <a href="https://thebiglead.com/tag/ucla/" rel="tag">UCLA</a>, <a href="https://thebiglead.com/category/nfl/" rel="category tag">NFL</a></p>
						<div class="story-share-buttons sms">
	<div class="share-button share-count">
		<span class="icomoon icon-shares"></span>
		<span class="count">2.0k</span>
		<span class="share-text">shares</span>
	</div>
	<div
		data-url="https://thebiglead.com/2018/03/27/jim-mora-josh-rosen-sam-darnold/"
		data-short-url="https://wp.me/p3LRnW-2zpw"
		data-track="thebigleadstoryfb"
		class="share-button share-facebook st-custom-button"
		id="share-facebook"
		data-network="facebook"
	>
		<span class="icomoon icon-facebook"></span>
		<span class="share-text">share</span>
	</div>
	<div
		data-url="https://thebiglead.com/2018/03/27/jim-mora-josh-rosen-sam-darnold/"
		data-short-url="https://wp.me/p3LRnW-2zpw"
		data-track="thebigleadstorytwitter"
		class="share-button share-twitter st-custom-button"
		id="share-twitter"
		data-network="twitter"
		data-username="thebiglead"
	>
		<span class="icomoon icon-twitter"></span>
		<span class="share-text">tweet</span>
	</div>
	<div
		data-url="https://thebiglead.com/2018/03/27/jim-mora-josh-rosen-sam-darnold/"
		data-short-url="https://wp.me/p3LRnW-2zpw"
		data-track="thebigleadstorypinterest"
		class="share-button share-pinterest st-custom-button"
		id="share-pinterest"
		data-network="pinterest"
		data-username=""
	>
		<span class="icomoon icon-pinterest"></span>
		<span class="share-text">pin</span>
	</div>
	<div
		data-url="https://thebiglead.com/2018/03/27/jim-mora-josh-rosen-sam-darnold/"
		data-short-url="https://wp.me/p3LRnW-2zpw"
		data-track="thebigleadstorysms"
		class="share-button share-sms st-custom-button"
		id="share-sms"
		data-network="sms"
	>
		<span class="icomoon icon-sms"></span>
		<span class="share-text">sms</span>
	</div>
	<div
		data-url="https://thebiglead.com/2018/03/27/jim-mora-josh-rosen-sam-darnold/"
		data-short-url="https://wp.me/p3LRnW-2zpw"
		data-track="thebigleadstorywhatsapp"
		class="share-button share-whatsapp st-custom-button"
		id="share-whatsapp"
		data-network="whatsapp"
	>
		<span class="icomoon icon-whatsapp"></span>
		<span class="share-text">send</span>
	</div>

			<div
			data-url="https://thebiglead.com/2018/03/27/jim-mora-josh-rosen-sam-darnold/"
			data-short-url="https://wp.me/p3LRnW-2zpw"
			data-track="thebigleadstoryemail"
			class="share-button share-email st-custom-button"
			id="share-email"
			data-network="email"
			data-message=""
		>
				<span class="icomoon icon-email"></span>
			<span class="share-text">email</span>
		</div>
</div>
					</div><!-- .entry-content -->
				</div><!-- #content-container -->

				
			</article><!-- #post-## -->

		
		<div class="container divider"></div><aside class="width widget--author author main-column">
	<img width="90" height="90" src="https://usatthebiglead.files.wordpress.com/2015/03/gravatar.jpg?w=90&#038;h=90&#038;crop=1" class="author__profile" alt="Kyle Koster"/>
	<h3 class="author__name">
		Kyle Koster	</h3>

	<span
	class="fb-like author__facebook"
	data-href="https://www.facebook.com/kyle.a.koster"
	data-layout="button"
	data-action="like"
	data-show-faces="true"
	data-share="false"
></span>
<script>(function(d, s, id) {
var js, fjs = d.getElementsByTagName(s)[0];
if (d.getElementById(id)) return;
js = d.createElement(s); js.id = id;
js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.3";
fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));
</script>
<span class="author-twitter-follow-button author__twitter">
	<a href="http://twitter.com/KyleKoster" class="twitter-follow-button" data-show-count="false">
		Follow @KyleKoster	</a>
	<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
</span>

	<p class="author__description">
		Kyle is a senior writer for The Big Lead, a Michigan State alum and a recovering former member of the newspaper industry. Send criticism, constructive or otherwise, to kylekoster@gmail.com	</p>

	<a href="https://thebiglead.com/author/Koster/" class="author__archive">More &hellip;</a>
</aside>

<div class="container single-related">

		<div class="heading-small">
		<h2>More Leads <span></span></h2>
	</div>
	
	<div class="holder-column">
		<div class="column">
			<article class="block block-single-related" itemscope itemtype="http://schema.org/NewsArticle">
	<a href="https://thebiglead.com/2018/02/26/the-perception-that-josh-rosen-has-a-bad-attitude-could-cost-him-millions/"
	   data-track="thebigleadfeaturedstories thebigleadmore-related-1"
	   title="The Perception that Josh Rosen Has a Bad Attitude Could Cost Him Millions"
	   class="link fixed-height-img-holder responsiveshort"
	   rel="nofollow"
					style="background-image: url('https://usatthebiglead.files.wordpress.com/2018/02/gettyimages-615842454.jpg?w=295&#038;h=231&#038;crop=1');"
			   itemprop="url">

					<img src="https://usatthebiglead.files.wordpress.com/2018/02/gettyimages-615842454.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165" alt="The Perception that Josh Rosen Has a Bad Attitude Could Cost Him Millions" itemprop="image">
		
		<span class="ie-overlay-hack"></span>

		
			</a>

	<div class="text-block">

		<span class="block__shares">85 shares</span><span class="block__time block__time--mobile">5w ago</span>
		<h2><a href="https://thebiglead.com/category/nfl/" class="category" itemprop="articleSection">NFL</a></h2>

		<p>
			<a data-track="thebigleadfeaturedstories thebigleadmore-related-1" href="https://thebiglead.com/2018/02/26/the-perception-that-josh-rosen-has-a-bad-attitude-could-cost-him-millions/"
			   title="The Perception that Josh Rosen Has a Bad Attitude Could Cost Him Millions" itemprop="url">
				The Perception that Josh Rosen Has a Bad Attitude Could Cost Him Millions			</a>
		</p>

	</div>
</article>
<article class="block block-single-related" itemscope itemtype="http://schema.org/NewsArticle">
	<a href="https://thebiglead.com/2018/03/05/aj-mccarron-cleveland-browns-nfl-draft-nfl-combine-hue-jackson/"
	   data-track="thebigleadfeaturedstories thebigleadmore-related-2"
	   title="Browns Want AJ McCarron in Free Agency, and Then Would Pass on a QB With 1st Pick in the Draft"
	   class="link fixed-height-img-holder responsiveshort"
	   rel="nofollow"
					style="background-image: url('https://usatthebiglead.files.wordpress.com/2015/12/usatsi_8994770_153192880_lowres.jpg?w=295&#038;h=231&#038;crop=1');"
			   itemprop="url">

					<img src="https://usatthebiglead.files.wordpress.com/2015/12/usatsi_8994770_153192880_lowres.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165" alt="Browns Want AJ McCarron in Free Agency, and Then Would Pass on a QB With 1st Pick in the Draft" itemprop="image">
		
		<span class="ie-overlay-hack"></span>

		
			</a>

	<div class="text-block">

		<span class="block__shares">516 shares</span><span class="block__time block__time--mobile">4w ago</span>
		<h2><a href="https://thebiglead.com/category/nfl/" class="category" itemprop="articleSection">NFL</a></h2>

		<p>
			<a data-track="thebigleadfeaturedstories thebigleadmore-related-2" href="https://thebiglead.com/2018/03/05/aj-mccarron-cleveland-browns-nfl-draft-nfl-combine-hue-jackson/"
			   title="Browns Want AJ McCarron in Free Agency, and Then Would Pass on a QB With 1st Pick in the Draft" itemprop="url">
				Browns Want AJ McCarron in Free Agency, and Then Would Pass on a QB With 1st Pick in the Draft			</a>
		</p>

	</div>
</article>
<article class="block block-single-related" itemscope itemtype="http://schema.org/NewsArticle">
	<a href="https://thebiglead.com/2018/03/04/saquon-barkley-nfl-draft-quarterback-browns-josh-allen/"
	   data-track="thebigleadfeaturedstories thebigleadmore-related-3"
	   title="If The Browns Take Saquon Barkley First, They Risk Missing Out On A Quarterback"
	   class="link fixed-height-img-holder responsiveshort"
	   rel="nofollow"
					style="background-image: url('https://usatthebiglead.files.wordpress.com/2018/03/usatsi_10669110_153192880_lowres.jpg?w=295&#038;h=231&#038;crop=1');"
			   itemprop="url">

					<img src="https://usatthebiglead.files.wordpress.com/2018/03/usatsi_10669110_153192880_lowres.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165" alt="If The Browns Take Saquon Barkley First, They Risk Missing Out On A Quarterback" itemprop="image">
		
		<span class="ie-overlay-hack"></span>

		
			</a>

	<div class="text-block">

		<span class="block__shares">89 shares</span><span class="block__time block__time--mobile">4w ago</span>
		<h2><a href="https://thebiglead.com/category/nfl/" class="category" itemprop="articleSection">NFL</a></h2>

		<p>
			<a data-track="thebigleadfeaturedstories thebigleadmore-related-3" href="https://thebiglead.com/2018/03/04/saquon-barkley-nfl-draft-quarterback-browns-josh-allen/"
			   title="If The Browns Take Saquon Barkley First, They Risk Missing Out On A Quarterback" itemprop="url">
				If The Browns Take Saquon Barkley First, They Risk Missing Out On A Quarterback			</a>
		</p>

	</div>
</article>

		</div>
	</div>
</div>
<div class="container single-related single-related--zergnet is-wasabi" id="single-related-zergnet-lawrence">
		<div class="heading-small"><h2>From <span>The Web</span></h2></div>
		<div id="zergnet-widget-61501" class="zergnet-wrapper"></div>
	</div><div class="container single-related container--comments">
	<div class="heading-small">
		<h2>Comments</h2>
	</div>

	<div id="disqus_thread">
	<div id="dsq-content">
		<ul id="dsq-comments">
					</ul>
			</div>
</div>
		
<a href="http://disqus.com" class="dsq-brlink">blog comments powered by <span class="logo-disqus">Disqus</span></a>

<script type="text/javascript" charset="utf-8">
	var disqus_url = "https:\/\/thebiglead.com\/2018\/03\/27\/jim-mora-josh-rosen-sam-darnold\/";
	var disqus_identifier = "612778 http:\/\/thebiglead.com\/?p=612778";
	var disqus_container_id = 'disqus_thread';
	var disqus_domain = "disqus.com";
	var disqus_shortname = "thebiglead";
		var disqus_config = function () {
	    var config = this; // Access to the config object

	    /* 
	       All currently supported events:
	        * preData — fires just before we request for initial data
	        * preInit - fires after we get initial data but before we load any dependencies
	        * onInit  - fires when all dependencies are resolved but before dtpl template is rendered
	        * afterRender - fires when template is rendered but before we show it
	        * onReady - everything is done
	     */

		config.callbacks.preData.push(function() {
			// clear out the container (its filled for SEO/legacy purposes)
			document.getElementById(disqus_container_id).innerHTML = '';
		})
		config.callbacks.onReady.push(function() {
/*
			// sync comments in the background so we don't block the page
			var req = new XMLHttpRequest();
			req.open('GET', '?cf_action=sync_comments&post_id=612778', true);
			req.send(null);
*/
		});
		
			};
	
	var facebookXdReceiverPath = "http:\/\/usatthebiglead.wordpress.com\/wp-content\/themes\/vip\/plugins\/disqus\/xd_receiver.htm";
</script>

<script type="text/javascript" charset="utf-8">
	var DsqLocal = {
		'trackbacks': [
		],
		'trackback_url': "https:\/\/thebiglead.com\/2018\/03\/27\/jim-mora-josh-rosen-sam-darnold\/trackback\/"	};
</script>

<script type="text/javascript" charset="utf-8">
(function() {
	var dsq = document.createElement('script'); dsq.type = 'text/javascript';
	dsq.async = true;
	dsq.src = '//' + disqus_shortname + '.' + disqus_domain + '/embed.js?pname=wordpress&pver=2.40';
	(document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
})();
</script>
</div>
<div class="container column container--stories">
	<div class="heading-small">
		<h2>Latest Leads</h2>
	</div>
	<div id='acm-ad-tag-lawrence_dfp_desktop_native' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_desktop_native'); });</script></div><article class="block block--hero">
	<a
		data-track="thebigleadmostrecent"
		href="https://thebiglead.com/2018/03/27/video-ronda-rousey-and-mike-golic-had-an-awkward-interaction/"
		title="VIDEO: Ronda Rousey and Mike Golic Had an Awkward Interaction"
		rel=""
		itemprop="url"
		class="block__link"
			>
		<img
			src="https://usatthebiglead.files.wordpress.com/2018/03/screen-shot-2018-03-27-at-10-13-47-am-e1522163671515.png?w=680&#038;h=399&#038;crop=1"
			width="680"
			height="399"
			alt="VIDEO: Ronda Rousey and Mike Golic Had an Awkward Interaction"
			itemprop="image"
			class="block__image"
		>
			</a>
	<div class="block__content">
		<h4 class="block__category">
			<a href="https://thebiglead.com/category/wwe/" class="block__category__link" itemprop="articleSection">WWE</a>		</h4>
		<h2 class="block__title">
			<a
				data-track="thebigleadmostrecent"
				href="https://thebiglead.com/2018/03/27/video-ronda-rousey-and-mike-golic-had-an-awkward-interaction/"
				title="VIDEO: Ronda Rousey and Mike Golic Had an Awkward Interaction"
				itemprop="url"
				rel=""
				class="block__title__link"
							>
					VIDEO: Ronda Rousey and Mike Golic Had an Awkward Interaction			</a>
		</h2>
							
<div class="meta" onclick="location.href='https://thebiglead.com/2018/03/27/video-ronda-rousey-and-mike-golic-had-an-awkward-interaction/';">
	<div class="reply-block">
		<a
			data-track="thebigleadmostrecent"
			href="https://thebiglead.com/2018/03/27/video-ronda-rousey-and-mike-golic-had-an-awkward-interaction/"
			title="VIDEO: Ronda Rousey and Mike Golic Had an Awkward Interaction"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>269</span>
		shares	</span>
</span>
			</div>
</div>
			</div>
</article>
<article class="block block--hero">
	<a
		data-track="thebigleadmostrecent"
		href="https://thebiglead.com/2018/03/27/markelle-fultz-76ers-lebron-joel-embiid-ben-simmons/"
		title="Markelle Fultz Looked Great in Return to the 76ers, Which Could Help Philly Become Legit Lebron Contenders"
		rel=""
		itemprop="url"
		class="block__link"
			>
		<img
			src="https://usatthebiglead.files.wordpress.com/2018/03/usatsi_10738298.jpg?w=680&#038;h=420&#038;crop=1"
			width="680"
			height="420"
			alt="Markelle Fultz Looked Great in Return to the 76ers, Which Could Help Philly Become Legit Lebron Contenders"
			itemprop="image"
			class="block__image"
		>
			</a>
	<div class="block__content">
		<h4 class="block__category">
			<a href="https://thebiglead.com/category/nba/" class="block__category__link" itemprop="articleSection">NBA</a>		</h4>
		<h2 class="block__title">
			<a
				data-track="thebigleadmostrecent"
				href="https://thebiglead.com/2018/03/27/markelle-fultz-76ers-lebron-joel-embiid-ben-simmons/"
				title="Markelle Fultz Looked Great in Return to the 76ers, Which Could Help Philly Become Legit Lebron Contenders"
				itemprop="url"
				rel=""
				class="block__title__link"
							>
					Markelle Fultz Looked Great in Return to the 76ers, Which Could Help Philly Become Legit Lebron Contenders			</a>
		</h2>
					</div>
</article>

		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="thebigleadmostrecent"
						href="https://thebiglead.com/2018/03/27/todd-bowles-with-best-smokescreen-ever-jets-traded-up-from-6th-pick-to-3rd-with-6-7-guys-in-mind/"
						title="Todd Bowles With Best Smokescreen Ever? Jets Traded Up From 6th Pick to 3rd With 6-7 Guys In Mind"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usatthebiglead.files.wordpress.com/2017/08/usatsi_9767896.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usatthebiglead.files.wordpress.com/2017/08/usatsi_9767896.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Todd Bowles With Best Smokescreen Ever? Jets Traded Up From 6th Pick to 3rd With 6-7 Guys In Mind" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="thebigleadmostrecent"
								href="https://thebiglead.com/2018/03/27/todd-bowles-with-best-smokescreen-ever-jets-traded-up-from-6th-pick-to-3rd-with-6-7-guys-in-mind/"
								title="Todd Bowles With Best Smokescreen Ever? Jets Traded Up From 6th Pick to 3rd With 6-7 Guys In Mind"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									<span class="dsq-postid" rel="612786 https://thebiglead.com/?p=612786">View Comments</span>							</a>
											</a>

											
<div class="meta" onclick="location.href='https://thebiglead.com/2018/03/27/todd-bowles-with-best-smokescreen-ever-jets-traded-up-from-6th-pick-to-3rd-with-6-7-guys-in-mind/';">
	<div class="reply-block">
		<a
			data-track="thebigleadmostrecent"
			href="https://thebiglead.com/2018/03/27/todd-bowles-with-best-smokescreen-ever-jets-traded-up-from-6th-pick-to-3rd-with-6-7-guys-in-mind/"
			title="Todd Bowles With Best Smokescreen Ever? Jets Traded Up From 6th Pick to 3rd With 6-7 Guys In Mind"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>88</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				1hr			</div>

			<div class="content  ">
				
				<h3>
										<a
						data-track="thebigleadmostrecent"
						href="https://thebiglead.com/2018/03/27/todd-bowles-with-best-smokescreen-ever-jets-traded-up-from-6th-pick-to-3rd-with-6-7-guys-in-mind/"
						title="Todd Bowles With Best Smokescreen Ever? Jets Traded Up From 6th Pick to 3rd With 6-7 Guys In Mind"
						itemprop="url" 						>
							Todd Bowles With Best Smokescreen Ever? Jets Traded Up From 6th Pick to 3rd With 6-7 Guys In Mind					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">2 hours ago </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="https://thebiglead.com/author/jason-lisk/" title="Posts by Jason Lisk" class="author url fn" rel="author">Jason Lisk</a>													</span>
					</p>
				</footer>

				<p>Smokescreen attempt, or the Jets being the Jets? </p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="thebigleadmostrecent"
						href="https://thebiglead.com/2018/03/27/stormy-daniels-pacific-rim-facebook-loyola-ncaa-tournament/"
						title="Roundup: Stormy Daniels Got Monster TV Ratings for 60 Minutes; Dillian Whyte&#039;s Violent Knockout; &amp; the Latest on the NFL and Gambling"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usatthebiglead.files.wordpress.com/2018/03/gettyimages-927534598-e1522080544599.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usatthebiglead.files.wordpress.com/2018/03/gettyimages-927534598-e1522080544599.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Roundup: Stormy Daniels Got Monster TV Ratings for 60 Minutes; Dillian Whyte&#039;s Violent Knockout; &amp; the Latest on the NFL and Gambling" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="thebigleadmostrecent"
								href="https://thebiglead.com/2018/03/27/stormy-daniels-pacific-rim-facebook-loyola-ncaa-tournament/"
								title="Roundup: Stormy Daniels Got Monster TV Ratings for 60 Minutes; Dillian Whyte&#039;s Violent Knockout; &amp; the Latest on the NFL and Gambling"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									<span class="dsq-postid" rel="612612 https://thebiglead.com/?p=612612">View Comments</span>							</a>
											</a>

											
<div class="meta" onclick="location.href='https://thebiglead.com/2018/03/27/stormy-daniels-pacific-rim-facebook-loyola-ncaa-tournament/';">
	<div class="reply-block">
		<a
			data-track="thebigleadmostrecent"
			href="https://thebiglead.com/2018/03/27/stormy-daniels-pacific-rim-facebook-loyola-ncaa-tournament/"
			title="Roundup: Stormy Daniels Got Monster TV Ratings for 60 Minutes; Dillian Whyte&#039;s Violent Knockout; &amp; the Latest on the NFL and Gambling"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>403</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				3hr			</div>

			<div class="content  ">
				
				<h3>
										<a
						data-track="thebigleadmostrecent"
						href="https://thebiglead.com/2018/03/27/stormy-daniels-pacific-rim-facebook-loyola-ncaa-tournament/"
						title="Roundup: Stormy Daniels Got Monster TV Ratings for 60 Minutes; Dillian Whyte&#039;s Violent Knockout; &amp; the Latest on the NFL and Gambling"
						itemprop="url" 						>
							Roundup: Stormy Daniels Got Monster TV Ratings for 60 Minutes; Dillian Whyte&#039;s Violent Knockout; &amp; the Latest on the NFL and Gambling					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">4 hours ago </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="https://thebiglead.com/author/thebiglead2013/" title="Posts by Jason McIntyre" class="author url fn" rel="author">Jason McIntyre</a>													</span>
					</p>
				</footer>

				<p> <em>Kate Beckinsale, actress &#8230; the US government is officially investigating Facebook &#8230; imagine losing your &#8216;dream (&#8230;)</em></p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="thebigleadmostrecent"
						href="https://thebiglead.com/2018/03/26/video-cristiano-ronaldo-kissed-by-male-pitch-invader-didnt-appear-thrilled-about-it/"
						title="VIDEO: Cristiano Ronaldo Kissed By Male Pitch Invader, Didn&#039;t Appear Thrilled About it"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usatthebiglead.files.wordpress.com/2018/03/screen-shot-2018-03-26-at-7-12-34-pm.png?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usatthebiglead.files.wordpress.com/2018/03/screen-shot-2018-03-26-at-7-12-34-pm.png?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="VIDEO: Cristiano Ronaldo Kissed By Male Pitch Invader, Didn&#039;t Appear Thrilled About it" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="thebigleadmostrecent"
								href="https://thebiglead.com/2018/03/26/video-cristiano-ronaldo-kissed-by-male-pitch-invader-didnt-appear-thrilled-about-it/"
								title="VIDEO: Cristiano Ronaldo Kissed By Male Pitch Invader, Didn&#039;t Appear Thrilled About it"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									<span class="dsq-postid" rel="612757 https://thebiglead.com/?p=612757">View Comments</span>							</a>
											</a>

											
<div class="meta" onclick="location.href='https://thebiglead.com/2018/03/26/video-cristiano-ronaldo-kissed-by-male-pitch-invader-didnt-appear-thrilled-about-it/';">
	<div class="reply-block">
		<a
			data-track="thebigleadmostrecent"
			href="https://thebiglead.com/2018/03/26/video-cristiano-ronaldo-kissed-by-male-pitch-invader-didnt-appear-thrilled-about-it/"
			title="VIDEO: Cristiano Ronaldo Kissed By Male Pitch Invader, Didn&#039;t Appear Thrilled About it"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>59</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				15hr			</div>

			<div class="content  ">
				
				<h3>
										<a
						data-track="thebigleadmostrecent"
						href="https://thebiglead.com/2018/03/26/video-cristiano-ronaldo-kissed-by-male-pitch-invader-didnt-appear-thrilled-about-it/"
						title="VIDEO: Cristiano Ronaldo Kissed By Male Pitch Invader, Didn&#039;t Appear Thrilled About it"
						itemprop="url" 						>
							VIDEO: Cristiano Ronaldo Kissed By Male Pitch Invader, Didn&#039;t Appear Thrilled About it					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">16 hours ago </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="https://thebiglead.com/author/bobby-burack/" title="Posts by Bobby Burack" class="author url fn" rel="author">Bobby Burack</a>													</span>
					</p>
				</footer>

				<p>Ronaldo looked less than enthused. </p>

				
				
			</div>
		</article>
	<article class="block block--hero">
	<a
		data-track="thebigleadmostrecent"
		href="https://thebiglead.com/2018/03/26/the-giants-really-want-us-to-know-theyre-not-trading-odell-beckham-jr/"
		title="The Giants Really Want Us to Know They&#039;re Not Trading Odell Beckham Jr."
		rel=""
		itemprop="url"
		class="block__link"
			>
		<img
			src="https://usatthebiglead.files.wordpress.com/2018/03/gettyimages-859088904-e1522105053724.jpg?w=680&#038;h=420&#038;crop=1"
			width="680"
			height="420"
			alt="The Giants Really Want Us to Know They&#039;re Not Trading Odell Beckham Jr."
			itemprop="image"
			class="block__image"
		>
			</a>
	<div class="block__content">
		<h4 class="block__category">
			<a href="https://thebiglead.com/category/nfl/" class="block__category__link" itemprop="articleSection">NFL</a>		</h4>
		<h2 class="block__title">
			<a
				data-track="thebigleadmostrecent"
				href="https://thebiglead.com/2018/03/26/the-giants-really-want-us-to-know-theyre-not-trading-odell-beckham-jr/"
				title="The Giants Really Want Us to Know They&#039;re Not Trading Odell Beckham Jr."
				itemprop="url"
				rel=""
				class="block__title__link"
							>
					The Giants Really Want Us to Know They're Not Trading Odell Beckham Jr.			</a>
		</h2>
							
<div class="meta" onclick="location.href='https://thebiglead.com/2018/03/26/the-giants-really-want-us-to-know-theyre-not-trading-odell-beckham-jr/';">
	<div class="reply-block">
		<a
			data-track="thebigleadmostrecent"
			href="https://thebiglead.com/2018/03/26/the-giants-really-want-us-to-know-theyre-not-trading-odell-beckham-jr/"
			title="The Giants Really Want Us to Know They&#039;re Not Trading Odell Beckham Jr."
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>410</span>
		shares	</span>
</span>
			</div>
</div>
			</div>
</article>

		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="thebigleadmostrecent"
						href="https://thebiglead.com/2018/03/26/lauren-cohan-walking-dead-goals-for-each-mlb-team-ranking-the-final-four/"
						title="PM Roundup: Lauren Cohan; Goals For Each MLB Team; Ranking The Final Four"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usatthebiglead.files.wordpress.com/2018/03/gettyimages-458076818-e1522100176387.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usatthebiglead.files.wordpress.com/2018/03/gettyimages-458076818-e1522100176387.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="PM Roundup: Lauren Cohan; Goals For Each MLB Team; Ranking The Final Four" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="thebigleadmostrecent"
								href="https://thebiglead.com/2018/03/26/lauren-cohan-walking-dead-goals-for-each-mlb-team-ranking-the-final-four/"
								title="PM Roundup: Lauren Cohan; Goals For Each MLB Team; Ranking The Final Four"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									<span class="dsq-postid" rel="612648 https://thebiglead.com/?p=612648">View Comments</span>							</a>
											</a>

											
<div class="meta" onclick="location.href='https://thebiglead.com/2018/03/26/lauren-cohan-walking-dead-goals-for-each-mlb-team-ranking-the-final-four/';">
	<div class="reply-block">
		<a
			data-track="thebigleadmostrecent"
			href="https://thebiglead.com/2018/03/26/lauren-cohan-walking-dead-goals-for-each-mlb-team-ranking-the-final-four/"
			title="PM Roundup: Lauren Cohan; Goals For Each MLB Team; Ranking The Final Four"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>175</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				17hr			</div>

			<div class="content  ">
				
				<h3>
										<a
						data-track="thebigleadmostrecent"
						href="https://thebiglead.com/2018/03/26/lauren-cohan-walking-dead-goals-for-each-mlb-team-ranking-the-final-four/"
						title="PM Roundup: Lauren Cohan; Goals For Each MLB Team; Ranking The Final Four"
						itemprop="url" 						>
							PM Roundup: Lauren Cohan; Goals For Each MLB Team; Ranking The Final Four					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">18 hours ago </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="https://thebiglead.com/author/ryan-phillips/" title="Posts by Ryan Phillips" class="author url fn" rel="author">Ryan Phillips</a>													</span>
					</p>
				</footer>

				<p>Lauren Cohan, goals for each MLB team, ranking the Final Four and more. </p>

				
				
			</div>
		</article>
	<article class="block block--hero">
	<a
		data-track="thebigleadmostrecent"
		href="https://thebiglead.com/2018/03/26/odell-beckham-jr-trade-rams-giants/"
		title="Odell Beckham Jr. Rams Rumors Are Interesting, But Do Leaked NFL Trades Ever Actually Happen?"
		rel=""
		itemprop="url"
		class="block__link"
			>
		<img
			src="https://usatthebiglead.files.wordpress.com/2018/03/usatsi_10334735_153192880_lowres.jpg?w=680&#038;h=420&#038;crop=1"
			width="680"
			height="420"
			alt="Odell Beckham Jr. Rams Rumors Are Interesting, But Do Leaked NFL Trades Ever Actually Happen?"
			itemprop="image"
			class="block__image"
		>
			</a>
	<div class="block__content">
		<h4 class="block__category">
			<a href="https://thebiglead.com/category/nfl/" class="block__category__link" itemprop="articleSection">NFL</a>		</h4>
		<h2 class="block__title">
			<a
				data-track="thebigleadmostrecent"
				href="https://thebiglead.com/2018/03/26/odell-beckham-jr-trade-rams-giants/"
				title="Odell Beckham Jr. Rams Rumors Are Interesting, But Do Leaked NFL Trades Ever Actually Happen?"
				itemprop="url"
				rel=""
				class="block__title__link"
							>
					Odell Beckham Jr. Rams Rumors Are Interesting, But Do Leaked NFL Trades Ever Actually Happen?			</a>
		</h2>
							
<div class="meta" onclick="location.href='https://thebiglead.com/2018/03/26/odell-beckham-jr-trade-rams-giants/';">
	<div class="reply-block">
		<a
			data-track="thebigleadmostrecent"
			href="https://thebiglead.com/2018/03/26/odell-beckham-jr-trade-rams-giants/"
			title="Odell Beckham Jr. Rams Rumors Are Interesting, But Do Leaked NFL Trades Ever Actually Happen?"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>213</span>
		shares	</span>
</span>
			</div>
</div>
			</div>
</article>
<article class="block block--hero">
	<a
		data-track="thebigleadmostrecent"
		href="https://thebiglead.com/2018/03/26/nate-robinson-talks-flag-football-evolution-of-basketball-mike-dantoni-renaissance/"
		title="Nate Robinson Talks Flag Football, Evolution of Basketball, Mike D&#039;Antoni Renaissance"
		rel=""
		itemprop="url"
		class="block__link"
			>
		<img
			src="https://usatthebiglead.files.wordpress.com/2018/03/gettyimages-919681650-e1522095642814.jpg?w=680&#038;h=420&#038;crop=1"
			width="680"
			height="420"
			alt="Nate Robinson Talks Flag Football, Evolution of Basketball, Mike D&#039;Antoni Renaissance"
			itemprop="image"
			class="block__image"
		>
			</a>
	<div class="block__content">
		<h4 class="block__category">
			<a href="https://thebiglead.com/category/podcasts/" class="block__category__link" itemprop="articleSection">Podcasts</a>		</h4>
		<h2 class="block__title">
			<a
				data-track="thebigleadmostrecent"
				href="https://thebiglead.com/2018/03/26/nate-robinson-talks-flag-football-evolution-of-basketball-mike-dantoni-renaissance/"
				title="Nate Robinson Talks Flag Football, Evolution of Basketball, Mike D&#039;Antoni Renaissance"
				itemprop="url"
				rel=""
				class="block__title__link"
							>
					Nate Robinson Talks Flag Football, Evolution of Basketball, Mike D'Antoni Renaissance			</a>
		</h2>
					</div>
</article>

		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="thebigleadmostrecent"
						href="https://thebiglead.com/2018/03/26/billions-and-basketball-talk-with-buckets-co-host-rob-perez/"
						title="Billions and Basketball Talk With Buckets Co-Host Rob Perez"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usatthebiglead.files.wordpress.com/2018/03/rob-perez.png?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usatthebiglead.files.wordpress.com/2018/03/rob-perez.png?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Billions and Basketball Talk With Buckets Co-Host Rob Perez" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="thebigleadmostrecent"
								href="https://thebiglead.com/2018/03/26/billions-and-basketball-talk-with-buckets-co-host-rob-perez/"
								title="Billions and Basketball Talk With Buckets Co-Host Rob Perez"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									<span class="dsq-postid" rel="612735 https://thebiglead.com/?p=612735">View Comments</span>							</a>
											</a>

									</div>

			
			<div class="mobile-date">
				19hr			</div>

			<div class="content  ">
				
				<h3>
										<a
						data-track="thebigleadmostrecent"
						href="https://thebiglead.com/2018/03/26/billions-and-basketball-talk-with-buckets-co-host-rob-perez/"
						title="Billions and Basketball Talk With Buckets Co-Host Rob Perez"
						itemprop="url" 						>
							Billions and Basketball Talk With Buckets Co-Host Rob Perez					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">19 hours ago </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="https://thebiglead.com/author/ryan-glasspiegel/" title="Posts by Ryan Glasspiegel" class="author url fn" rel="author">Ryan Glasspiegel</a>													</span>
					</p>
				</footer>

				<p>Fun chat with TBL alum Rob Perez. </p>

				
				
			</div>
		</article>
	</div>
<div class="social-cta container column">

	<h2 class="social-cta__header">
		Follow The Big Lead!	</h2>

			<div class="social-cta__column social-cta__column--social">

			<h3 class="social-cta__type social-cta__type--social">Social</h3>
			<span class="social-cta__desc social-cta__desc--social">
				See Big Lead stories in your feed			</span>

							<a
					href="http://facebook.com/thebiglead"
					class="social-cta__button social-cta__button--facebook"
					target="_blank"
				>Like The Big Lead</a>
			
							<a
					href="https://twitter.com/thebiglead"
					class="social-cta__button social-cta__button--twitter"
					target="_blank"
				>Follow The Big Lead</a>
			
		</div>
	
	
			<div class="social-cta__column social-cta__column--podcast">

			<h3 class="social-cta__type social-cta__type--podcast">Podcast</h3>
			<span class="social-cta__desc social-cta__desc--podcast">
				Hear Big Lead writers out loud			</span>

			<a
				href="https://thebiglead.com/category/podcasts/"
				class="social-cta__button social-cta__button--podcast"
			>Latest podcast</a>

		</div>
	
</div>
<a href="https://thebiglead.com/category/nfl/" class="article__back">More NFL</a>

		
	</div><!-- #content -->
</div><!-- #primary -->


<div id="secondary" class="widget-area container sidebar--follow" role="complementary">

	
	<aside id="sidebar-read-more" class="widget sidebar-upper">

		<div class="widget sidebar-ad top">
			<div id='acm-ad-tag-lawrence_dfp_desktop_top_300x250' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_desktop_top_300x250'); });</script></div>		</div>

		
		<div class="widget widget--featured widget--box" id="featured_widget-2"><div class="heading-small"><h2>The Roundup</h2></div><article class="block" itemscope="" itemtype="http://schema.org/NewsArticle">

			<a
			style="background-image:url('https://usatthebiglead.files.wordpress.com/2018/03/gettyimages-927534598-e1522080544599.jpg?w=300');"
			data-track="thebigleadmostshared"
			href="https://thebiglead.com/2018/03/27/stormy-daniels-pacific-rim-facebook-loyola-ncaa-tournament/"
			title="Roundup: Stormy Daniels Got Monster TV Ratings for 60 Minutes; Dillian Whyte's Violent Knockout; &amp; the Latest on the NFL and Gambling"
			class="img-holder"
			rel="nofollow"
			itemprop="url"
		>
					</a>
	
	<div class="text-block">

					<h2>403 shares</h2>
		
		<p><a
			data-track="thebigleadmostshared"
			href="https://thebiglead.com/2018/03/27/stormy-daniels-pacific-rim-facebook-loyola-ncaa-tournament/"
			title="Roundup: Stormy Daniels Got Monster TV Ratings for 60 Minutes; Dillian Whyte's Violent Knockout; &amp; the Latest on the NFL and Gambling"
			itemprop="url"
		>Roundup: Stormy Daniels Got Monster TV Ratings for 60 Minutes; Dillian Whyte's Violent Knockout; &amp; the Latest on the NFL and Gambling</a></p>

	</div>
</article>
</div>		<div class="OUTBRAIN" data-src="https://thebiglead.com/2018/03/27/jim-mora-josh-rosen-sam-darnold/" data-widget-id="SB_1"
		data-ob-template="TheBigLead"></div>
		<script type="text/javascript" async="async" src="https://widgets.outbrain.com/outbrain.js"></script>
		
		<div class="widget sidebar-ad bottom">
			<div id='acm-ad-tag-lawrence_dfp_desktop_bottom_300x250' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_desktop_bottom_300x250'); });</script></div>		</div>

		
<div id="footer-info">
	<p class="footer__logo">
		<a href="http://usatodaysports.com" rel="nofollow" target="_blank">
			<img src="https://usatthebiglead.files.wordpress.com/2015/11/logo-usat-footer.png" alt="USA Today Sports">
		</a>
	</p>

	<div class="togglee">
		<div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="menu"><li id="menu-item-322221" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-322221"><a href="/privacy-policy/#adchoices">Ad Choices</a></li>
<li id="menu-item-321395" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-321395"><a href="https://thebiglead.com/privacy-policy/">Privacy Notice/Your California Privacy Rights</a></li>
<li id="menu-item-321396" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-321396"><a href="https://thebiglead.com/terms-of-use/">Terms of Service</a></li>
<li id="menu-item-16" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16"><a href="https://thebiglead.com/about/">About TheBigLead and Big Lead Sports</a></li>
</ul></div>
		
		<p class="poweredby-wordpress">
			Powered by <a href="https://vip.wordpress.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=thebiglead.com" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a>		</p>
	</div>

	<p class="toggler">
		<a href="#footer-toggle" rel="nofollow">
			More Information		</a>
		<span class="arrow-up"></span>
	</p>

	<script type="text/javascript">
		var footer_expand_text   = "More Information";
		var footer_collapse_text = "Hide Information";
	</script>
</div>

	</aside>

	<div id="secondary-bottom"></div>

</div><!-- #secondary -->
<div style="clear:both;"></div>
			</div><!-- Site Main -->
		</div><!-- Wrapper Holder -->
	</div><!-- Wrapper -->

	
	<!-- wpcom_wp_footer -->
	<script type="text/javascript">
	// <![CDATA[
		var disqus_shortname = "thebiglead";
		var disqus_domain = "disqus.com";
		(function () {
			var nodes = document.getElementsByTagName('span');
			for (var i = 0, url; i < nodes.length; i++) {
				if (nodes[i].className.indexOf('dsq-postid') != -1) {
					nodes[i].parentNode.setAttribute('data-disqus-identifier', nodes[i].getAttribute('rel'));
					url = nodes[i].parentNode.href.split('#', 1);
					if (url.length == 1) url = url[0];
					else url = url[1]
					nodes[i].parentNode.href = url + '#disqus_thread';
				}
			}
			var s = document.createElement('script'); s.async = true;
			s.type = 'text/javascript';
			s.src = '//' + disqus_domain + '/forums/' + disqus_shortname + '/count.js';
			(document.getElementsByTagName('HEAD')[0] || document.getElementsByTagName('BODY')[0]).appendChild(s);
		}());
	//]]>
	</script>
<div class="mobile-nav" id="mobile-nav-holder">
	<div class="mobile-nav__header">
					<img class="mobile-nav__logo" src="https://usatthebiglead.files.wordpress.com/2015/11/tbl_blue.png" alt="The Big Lead">
				<a class="mobile-nav__breadcrumb" href="https://thebiglead.com">Home</a>
		<span class="mobile-nav__close"></span>
	</div>
		<ul class="mobile-nav__social ">
					<li class="mobile-nav__item mobile-nav__item--stalk">Follow us&hellip;</li>
							<li class="mobile-nav__item mobile-nav__item--social mobile-nav__item--facebook">
				<a href="http://facebook.com/thebiglead" class="mobile-nav__item-link"></a>
			</li>
					<li class="mobile-nav__item mobile-nav__item--social mobile-nav__item--twitter">
				<a href="https://twitter.com/thebiglead" class="mobile-nav__item-link"></a>
			</li>
					<li class="mobile-nav__item mobile-nav__item--social mobile-nav__item--podcast">
				<a href="https://thebiglead.com/category/podcasts/" class="mobile-nav__item-link"></a>
			</li>
			</ul>
	<ul class="mobile-nav__menu">
		<li class="mobile-nav__item mobile-nav__item--nfl"><a href="https://thebiglead.com/category/nfl/">NFL</a></li>
<li class="mobile-nav__item mobile-nav__item--ncaaf"><a href="https://thebiglead.com/category/college-football/">NCAAF</a></li>
<li class="mobile-nav__item mobile-nav__item--nba"><a href="https://thebiglead.com/category/nba/">NBA</a></li>
<li class="mobile-nav__item mobile-nav__item--ncaab"><a href="https://thebiglead.com/category/college-basketball/">NCAAB</a></li>
<li class="mobile-nav__item mobile-nav__item--mlb"><a href="https://thebiglead.com/category/mlb/">MLB</a></li>
<li class="mobile-nav__item mobile-nav__item--golf"><a href="https://thebiglead.com/category/golf/">GOLF</a></li>
<li class="mobile-nav__item mobile-nav__item--media"><a href="https://thebiglead.com/category/media-gossipmusings/">MEDIA</a></li>
<li class="mobile-nav__item mobile-nav__item--soccer"><a href="https://thebiglead.com/category/soccer/">SOCCER</a></li>
<li class="mobile-nav__item mobile-nav__item--wwe"><a href="https://thebiglead.com/category/wwe/">WWE</a></li>
<li class="mobile-nav__item mobile-nav__item--wags"><a href="https://thebiglead.com/category/athlete-girlfriends/">WAGS</a></li>
<li class="mobile-nav__item mobile-nav__item--rugby"><a href="https://thebiglead.com/category/rugby/">RUGBY</a></li>
<li class="mobile-nav__item mobile-nav__item--roundup"><a href="https://thebiglead.com/category/roundup/">ROUNDUP</a></li>
<li class="mobile-nav__item mobile-nav__item--gifs"><a href="https://thebiglead.com/tag/gif/">GIFs</a></li>
<li class="mobile-nav__item mobile-nav__item--podcasts"><a href="https://thebiglead.com/category/podcasts/">PODCASTS</a></li>
	</ul>
	<ul class="mobile-nav__footer-menu">
		<li id="menu-item-322221" class="mobile-nav__item mobile-nav__item--ad-choices"><a href="/privacy-policy/#adchoices">Ad Choices</a></li>
<li id="menu-item-321395" class="mobile-nav__item mobile-nav__item--privacy-notice-your-california-privacy-rights"><a href="https://thebiglead.com/privacy-policy/">Privacy Notice/Your California Privacy Rights</a></li>
<li id="menu-item-321396" class="mobile-nav__item mobile-nav__item--terms-of-service"><a href="https://thebiglead.com/terms-of-use/">Terms of Service</a></li>
<li id="menu-item-16" class="mobile-nav__item mobile-nav__item--about-thebiglead-and-big-lead-sports"><a href="https://thebiglead.com/about/">About TheBigLead and Big Lead Sports</a></li>

		
					<li class="mobile-nav__item mobile-nav__item--vipcom">
				Powered by <a href="https://vip.wordpress.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=thebiglead.com" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a>			</li>
			</ul>

			<a
			class="mobile-nav__footer"
			href="http://usatodaysports.com"
			target="_blank"
			title="USA Today Sports"
			rel="nofollow"
		>
			<img class="mobile-nav__footer-image" src="https://usatthebiglead.files.wordpress.com/2015/11/usat-logo-mobile-off-canvas.png">
		</a>
	</div>

	<!-- SimpleReach Analytics -->
	<script type='text/javascript' id='simplereach-analytics-tag'>

		
			var __reach_config = {"pid":"533ac697330afd254f000004","title":"Josh Rosen's Former Coach: Draft Sam Darnold","url":"https:\/\/thebiglead.com\/2018\/03\/27\/jim-mora-josh-rosen-sam-darnold\/","date":"2018-03-27 12:53:26","authors":["Kyle Koster"],"channels":["NFL"],"tags":["Cleveland Browns","Jim Mora","Josh Rosen","News","NFL Draft","Sam Darnold","UCLA"]};

		
	</script>

<div id="main_ad" style="height:1px; width:1px; overflow:auto;position: absolute;left: -999em;"><!--AD UNIT 4--></div><script src="https://run.adrizer.com/track.js" id="ADRIZER_JS" data-domain="thebiglead.com/"></script><script type='text/javascript' src='//0.gravatar.com/js/gprofiles.js?ver=201813y'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/wp-content/mu-plugins/gravatar-hovercards/wpgroho.js?m=1380573781h'></script>

	<script>
		//initialize and attach hovercards to all gravatars
		jQuery( document ).ready( function( $ ) {

			if (typeof Gravatar === "undefined"){
				return;
			}

			if ( typeof Gravatar.init !== "function" ) {
				return;
			}			

			Gravatar.profile_cb = function( hash, id ) {
				WPGroHo.syncProfileData( hash, id );
			};
			Gravatar.my_hash = WPGroHo.my_hash;
			Gravatar.init( 'body', '#wp-admin-bar-my-account' );
		});
	</script>

		<div style="display:none">
	</div>
<script src="https://run.adrizer.com/track.js" id="ADRIZER_JS" data-domain="thebiglead.com/"></script><script type='text/javascript'>
/* <![CDATA[ */
var HighlanderComments = {"loggingInText":"Logging In\u2026","submittingText":"Posting Comment\u2026","postCommentText":"Post Comment","connectingToText":"Connecting to %s","commentingAsText":"%1$s: You are commenting using your %2$s account.","logoutText":"Log Out","loginText":"Log In","connectURL":"https:\/\/usatthebiglead.wordpress.com\/public.api\/connect\/?action=request","logoutURL":"https:\/\/usatthebiglead.wordpress.com\/wp-login.php?action=logout&_wpnonce=cda18a75a3","homeURL":"https:\/\/thebiglead.com\/","postID":"612778","gravDefault":"identicon","enterACommentError":"Please enter a comment","enterEmailError":"Please enter your email address here","invalidEmailError":"Invalid email address","enterAuthorError":"Please enter your name here","gravatarFromEmail":"This picture will show whenever you leave a comment. Click to customize it.","logInToExternalAccount":"Log in to use details from one of these accounts.","change":"Change","changeAccount":"Change Account","comment_registration":"","userIsLoggedIn":"","isJetpack":"","text_direction":"ltr"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/_static/??/wp-content/js/jquery/jquery.autoresize.js,/wp-content/mu-plugins/highlander-comments/script.js?m=1521806916j'></script>
<link rel='stylesheet' id='all-css-0-3' href='https://s0.wp.com/wp-content/themes/vip/usatoday-lawrence/modules/zergnet/css/zergnet.css?m=1507314031h&cssminify=yes' type='text/css' media='all' />
<script type='text/javascript' src='https://s1.wp.com/_static/??/wp-content/js/devicepx.js,/wp-content/mu-plugins/likes/queuehandler.js?m=1519172360j'></script>
<script type='text/javascript' src='https://native.sharethrough.com/assets/sfp.js?ver=1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var stickyInlineVideosOptions = {"side":"right"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var _LAWRENCE_MAIN_EXPORTS = {"right_rail_ad_delay":{"distance":"200000","seconds":"1000","active":"0"}};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcomVipAnalytics = {"is_404":"0","is_home":"0","is_single":"1","is_front_page":"0","is_archive":"0","percentToTrack":"1"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var wasabiFacebookReferral = "1";
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var wasabiAdFollowOptions = {"headerAdPosition":"0","enable":"1","maxDistance":"1300","medAdHeight":"239","maxDistanceMed":"600","largeAdHeight":"400","maxDistanceLarge":"0","isDesktop":"1","headerHeight":"100"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??-eJydUltug0AMvFCXzUNp+lP1KJUDFjXsg64NlJ6+JmrSSkkp8LeyPLMz47F9Y/IYBINYeUOPbDtqbMsgsYDBNK4tKbBlobweDAVHAU1HBUa21f15VvGD/YfXQZ8w5DhyODrZ6r3FNGR5jDXhUgIPFJZiBMFR6w1+6DpTDDeyfXt1X6E0kNf2lUJupScRTEbI4+h6Arcz4//VWYaBAG7QuKbyuQAdfKrcCIXZZMeR4DsfjgFS5ift/slxHczJ6sLSA8OJRngr5Gbd9hYaoKMSRFNeh2ft1UmNrwJD0tDdrFLdgu9V69eBodBbGJWmi6yl0JeJHaakgvlntpBBkpZtbdTYs8NzQXsqShSlefHP28Nuc9g+Ph331Rdrf3z+'></script>
<script type='text/javascript' src='https://www.zergnet.com/zerg.js?id=61501&#038;ver=1.0'></script>
<script type='text/javascript' src='https://platform-api.sharethis.com/js/sharethis.js#product=sop-wordpress-plugin'></script>
<script type="text/javascript">
// <![CDATA[
(function() {
try{
  if ( window.external &&'msIsSiteMode' in window.external) {
    if (window.external.msIsSiteMode()) {
      var jl = document.createElement('script');
      jl.type='text/javascript';
      jl.async=true;
      jl.src='/wp-content/plugins/ie-sitemode/custom-jumplist.php';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(jl, s);
    }
  }
}catch(e){}
})();
// ]]>
</script><script src="//stats.wp.com/w.js?56" type="text/javascript" async defer></script>
<script type="text/javascript">
_tkq = window._tkq || [];
_stq = window._stq || [];
_tkq.push(['storeContext', {'blog_id':'55735640','blog_tz':'-4','user_lang':'en','blog_lang':'en','user_id':'0'}]);
_stq.push(['view', {'blog':'55735640','v':'wpcom','tz':'-4','user_id':'0','post':'612778','subd':'usatthebiglead'}]);
function st_vt() {var x=document.createElement("img");x.src="https://pixel.wp.com/g.gif?blog=55735640&v=wpcomvt&tz=-4&user_id=0&post=612778&subd=usatthebiglead&rand="+Math.random();}
_stq.push(['extra', {'crypt':'UE40eW5QN0p8M2Y/RE1BNmNJfGhxNCVxUDExYmtib2E/SzdEJm0lUEtbdFU0fFk4cHZvcUFrZT90Tn4yQm1+R3NyNTcvN1dHVE8tU1Y5Tk5xJUNPdGUvNWlURCVDWHdySjhHMEF6azhRa2xxSC5tLj1TNUl6KzElPUtwb3Y4NTh2cHdwZC09TWElQkJ5X1srRnNQZndqdltiT2cxeCZLYiw2d1lXfkRmeW1Ga340RWJqNCt3QV1EbGwmOWF4JnNoelV5MlVsXW5+SWI9WTQvdVJrX2NSeUFWcFU0d3hSMXV0al9kPS5EPy02clduOS5PMl9fYmFBSTV2X0EsR3RTK3JsMnl6YURf'}]);
_stq.push([ 'clickTrackerInit', '55735640', '612778' ]);
	</script>
<noscript><img src="https://pixel.wp.com/b.gif?v=noscript" style="height:0px;width:0px;overflow:hidden" alt="" /></noscript>
<script>
if ( 'object' === typeof wpcom_mobile_user_agent_info ) {

	wpcom_mobile_user_agent_info.init();
	var mobileStatsQueryString = "";
	
	if( false !== wpcom_mobile_user_agent_info.matchedPlatformName )
		mobileStatsQueryString += "&x_" + 'mobile_platforms' + '=' + wpcom_mobile_user_agent_info.matchedPlatformName;
	
	if( false !== wpcom_mobile_user_agent_info.matchedUserAgentName )
		mobileStatsQueryString += "&x_" + 'mobile_devices' + '=' + wpcom_mobile_user_agent_info.matchedUserAgentName;
	
	if( wpcom_mobile_user_agent_info.isIPad() )
		mobileStatsQueryString += "&x_" + 'ipad_views' + '=' + 'views';

	if( "" != mobileStatsQueryString ) {
		new Image().src = document.location.protocol + '//pixel.wp.com/g.gif?v=wpcom-no-pv' + mobileStatsQueryString + '&baba=' + Math.random();
	}
	
}
</script></body>
</html>


<!--
$$\
$$ |
$$ |      $$$$$$\  $$\  $$\  $$\  $$$$$$\   $$$$$$\  $$$$$$$\   $$$$$$$\  $$$$$$\
$$ |      \____$$\ $$ | $$ | $$ |$$  __$$\ $$  __$$\ $$  __$$\ $$  _____|$$  __$$\
$$ |      $$$$$$$ |$$ | $$ | $$ |$$ |  \__|$$$$$$$$ |$$ |  $$ |$$ /      $$$$$$$$ |
$$ |     $$  __$$ |$$ | $$ | $$ |$$ |      $$   ____|$$ |  $$ |$$ |      $$   ____|
$$$$$$$$\$$$$$$$ |\$$$$$\$$$$  |$$ |      \$$$$$$$\ $$ |  $$ |\$$$$$$$\ \$$$$$$$\
\________|\_______| \_____\____/ \__|       \_______|\__|  \__| \_______| \_______|

Brought to you by your good friends at USA Today Sports.
-->
<!--
	generated 40 seconds ago
	generated in 0.988 seconds
	served from batcache in 0.002 seconds
	expires in 260 seconds
-->
